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Introduction
This FitAll Getting Started Guide provides an introduction to What's New in this version of FitAll and how
to get started using FitAll.

For more complete and detailed information consult the FitAll Reference Guide.
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New In FitAll version 10
FitAll version 10 has been enhanced to include the following new features:

? NEW: A Scripted Functions feature has been added. 
This makes is possible for you to add up to 100 functions to FitAll by filling out a simple form.

The advantages are:
(i) You can quickly add single-line custom function expressions to FitAll without the need for a
compiler.
(ii) Each function can contain one independent variable, X, and up to ten  (10) parameters, P,

The disadvantages are:
(i) FitAll will not be able to automatically determine the initial parameter estimates that are required
when analyzing nonlinear functions.
(ii) The regression analysis will be slower than if the function had been compiled into a FitAll function
library

? NEW: Almost all forms and dialogs now use the font that is set via the new Options > Change Font
menu selection.
This makes it easier to read the text on small, high resolution monitors.

? IMPROVED: Most dialogs and forms have been modified to make them easier to read.
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? CHANGED: FitAll Function Libraries can only be modified and compiled using the Lazarus / Free
Pascal Compiler, which is a free, open source Object Pascal compiler.
Support for the Delphi compiler was discontinued because most users found it to be too costly. 

? DISCONTINUED: Support for MS Windows Vista and earlier has been discontinued because they
are no longer supported by Microsoft.

? DISCONTINUED: Support for ActiveX / COM Automation.
That is, FitAll can no longer act as an automation server and be controlled by other programs using
ActiveX / COM automation.
(This was done because no current FitAll users are using or even contemplating using this feature.)

http://www.lazarus.freepascal.org/
http://www.lazarus.freepascal.org/
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New In FitAll version 9
FitAll version 9 has been enhanced to include the following new features:

· FitAll now takes advantage of some of the features that were introduced in MS Windows 8.1 and 10.

The most noticeable change is that FitAll now will automatically adjust the font and images sizes
when it is run on a computer with a high resolution monitor or its main window is moved to a monitor
that has a different resolution.

· The FitAll  API now has functions to determine the roots of 2nd  to 10th -order polynomials.

· The FitAll Chemistry Functions Library now has many new functions that can be used to determine
the concentration, and acid dissociation constants, pKa's, of weak monoprotic, diprotic and triprotic
acids as well as mixtures of monoprotic acids when titrated with a strong base. All of the solutions
may or may not contain a strong acid, the concentration of which also can determined.

· FitAll can now display help documents for the User Defined Functions, UDFs, that you have
created.

This makes it possible for you, your colleagues and your students to get some help for the functions
that you developed.

The help files can be MS Word (*doc, *.docx), Rich Text (*.rtf), Open Document Text (*.odt), Text
(*.txt) or Portable Document Format (*.pdf) files

· Support for MS Windows XP has been discontinued.
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New In FitAll version 8
FitAll version 8 has been enhanced to include the following new features:

· The most noticeable change is to the main user interface, which is of the "tabbed notebook" type
rather than the previous "multi-document" type.

This makes it easier to see which windows are open and to switch between them. The tabs may,
optionally, include a small icon (graphic) that indicates whether the tab contains text or a graph.

· Switching the X- (bottom) and Y- (left) axes has been improved to ensure that the axis captions are
properly switched.

· .All of the Solar Cell functions have been extended so that they can be used to analyze IV data
obtained from "modules" as well as from "single cells".

Previously, for a module with the solar cells connected in series, it was necessary to divide the
measured voltage values by the number of cells. Now, an adjustable constant, Ns, can be set to the
number of cells that are connected in series and the unmodified data can be directly analyzed.
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A similar situation also applies to modules in which the solar cells are connected in parallel.

· Several new functions, including but not limited to GammaP, GammaQ, IsInfinite, IsNAN, IsZero,
Sinh, Cosh, Tanh, have been added to the FitAll API. This makes it easier for programmers, who
are adding their own functions to FitAll Research Edition, to more easily add more complicated
functions of their own.

· FitAll now makes more efficient use of the computer's memory.

· FitAll now makes more efficient use of the computer's memory.

· MS Windows 8 is now supported.

· MS Windows 2000 support has been discontinued.
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What FitAll Does
FitAll is a general-purpose, nonlinear regression analysis (curve fitting) program that can be used to fit a
set of experimental data to any of the defined functions (models).

The 'best fit' is obtained by one of three methods:

· Linear Least Squares (lls): minimizes the sum of the squares of the deviations between the observed
and calculated values of a function that is linear in its parameters. (For more information see: Linear
Least Squares Method in the FitAll Reference Guide).

· Nonlinear Least Squares (nlls): minimizes the sum of the squares of the deviations between the
observed and calculated values. (For more information see: Nonlinear Least Squares Method in the
FitAll Reference Guide).

·  Nonlinear Least Absolute Deviations (nlad): minimizes the absolute deviations between the observed
and calculated values. (For more information see: Nonlinear Least Absolute Deviations Method in the
FitAll Reference Guide)

FitAll is a tool to use in analyzing data that characterize all kinds of phenomena studied by scientists,
engineers and students.

Some of the areas in which FitAll is being used are:

· biochemistry.

· biomedical research.

· cancer research.

· chemistry.

· corrosion.

· electrochemistry.

· enzymology.

· metallurgy.

· oceanography.

· pharmacology.

· petroleum research.

· reaction kinetics.

· semiconductor diode research.

· solar cell research.

FitAll fits data to continuous, single-valued:

functions with the general form:
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Yi = ƒ(Xij, KK, PP)

and 

implicit functions with the general form:

Yi = ƒ( Yi, Xij, KK, PP)

in which:

· Yi is the dependent variable (measured value of the function for the ith data point).

·  Xij is the set of j independent variables for the ith data point.

· Kk is a set of k constants.

·  Pp is the set of p parameters that are evaluated by FitAll.

FitAll can use weighting factors in the analysis.

FitAll provides two methods (Boxcar and Fourier transform) for smoothing data.

FitAll reports the standard deviation of the overall fit and of each parameter that it resolves.

FitAll makes two-dimensional graphs of the:

· original data.

· calculated curve.

· residuals (that is, the difference between the actual and the calculated values).

· parameter sensitivities.

· residual distribution.

FitAll automatically scales the graphs for you or you can specify the axis limits and the number of tic-
marks that should be used.

Graphs created by FitAll can be:

· displayed on the computer's screen.

· copied to the Windows Clipboard.

· printed.

· saved to a disk file in several different graphics formats.

FitAll creates tables containing:

· the original data.

· the data and the corresponding calculated values.
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· the resolved parameter values.

· the parameter sensitivities.

· the residual distribution.

· nonparametric statistics, such as, Kendall's tau and the sum squared difference of ranks.

Tables generated by FitAll can be:

· displayed on the computer's screen.

· copied to the Windows' Clipboard.

· printed.

· saved to disk as text files.

NOTE:
FitAll can, at the click of a button, create MS Word and Libre Office Writer
reports that can contain any or all of its graphs and tables.
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What FitAll Cannot Do
· FitAll can tell you which function gives the best fit; however, it cannot tell you which function is most

appropriate for your use. You must make that judgment.

· FitAll cannot guarantee that the results it produces are physically meaningful. You must make that
judgment based on your knowledge of the processes involved.
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What You Need to Use FitAll
To use FitAll you need the following:

1. A MS Windows 7 or later capable computer.

2. A hard disk with at least twenty megabytes (20 MB) of available space.

3. 256 MB of memory (1 GB or more recommended).

4. The FitAll program.

Optional equipment:

1. MS Office 2007 or later to generate the MS Word reports.

2. LibreOffice.org 5.x or later to generate LO Writer reports.
(LibreOffice is a free, open source office suite available from  https://www.libreoffice.org/.)

3. A MS Windows compatible printer to print the tables, graphs and reports created by FitAll.

To add your own functions as compiled FitAll Function Libraries.

1. FitAll Research Edition.

2. Lazarus / Free Pascal, which is a free, open source, Pascal compiler and is available from
http://www.lazarus.freepascal.org/ .

https://www.libreoffice.org/
http://www.lazarus.freepascal.org/
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How to Install FitAll
1. Download the file to a directory of your choice.

2. Use Windows Explorer to locate the file named fa?????.exe; for example, fa010P.exe.

3. Double click on the fa?????.exe file to run it.

4. Follow the on screen instructions.
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How to Uninstall FitAll
To uninstall (remove) FitAll from your computer:

Click on Start, Programs, FitAll70, Uninstall FitAll .

1. In Windows 7:
Click Start > Control Panel.

In Windows 10:
Click Start > Settings

2. In Windows 7:
Click Programs  > Programs and Features > Uninstall a program.

In Windows 8:
Double-click the Control Panel desktop icon and then click Uninstall a program.

In Windows 10:
Click Apps (uninstall defaults, optional features)

3. Click on the FitAll item to select it.

4. In Windows 7:
Click the Ok or Change/Remove button.

In Windows 10:
Click the Uninstall button.

5. Follow the on-screen instructions.
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Starting FitAll
To start FitAll:

Double click on the  icon. (If you followed the standard setup procedure, the FitAll icon will be
located on your desktop). -- Or select (click): Start > Programs > FitAll10.

The first time that you start FitAll: 

· The 'Edit Serial Number' dialog box may appear. It looks like this:

· Enter your serial number.

· Click the OK button.

After a brief pause, FitAll's main window will appear. It should look like this:



- 18 -

Getting Started GuideFitAll Fundamentals, Starting FitAll

· The main menu is displayed across the top of the window.

· Below the menu is a toolbar, which has buttons representing the most commonly used commands.

· At the bottom of the main window there is a status line in which messages may appear.

· On the right side of the status line there are two progress bars.
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Opening a Data File
To retrieve an existing set of data:

Click the File > Open menu selections, press Ctrl+O or click the  button.

The File Open dialog box will appear. It should look like this:

Navigate to the Data directory and click on 'f0001tst.dta' to select this file as the one to open.

Your screen should look like this:
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NOTE:
FitAll normally expects data files to have the file name extension ".DTA".

If you choose to open a file with a different file name extension, FitAll will still
read it as long as it has the correct structure (See: 'DTA Files' in the FitAll
Reference Guide).

 Click the Open button.

FitAll will retrieve the data and place it in its 'Data' window. Your screen should look like this:
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Graphing the Data
To see a graph of the data:

· Click the View > data graph menu selections.

· FitAll will open its 'data graph' window and place the graph in it. Your screen should look like this:

To change the appearance of the data graph:

· Select the menu item Edit > Properties... or right-click anywhere in the data graph window and select the
Properties... item on the resulting context menu.

The Properties dialog will appear. It should look like this:
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· Make whatever changes you want and click the Ok button. For example, do the following:

· Click on the 'Bottom Axis' tab.

· Use the 'Label Fmt:' drop down list to change the format from '0.00' to '0'.

· Click on the 'Left Axis' tab.

· In the Scale Style group box, click the 'Log' radio button.

· Click the Ok button.

The graph window should now look like this:
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The Properties dialog box provides many other options for changing the appearance of the graph.

Most of the settings are saved when the window is closed and are used again when the same window is
next displayed.
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Setting up the Analysis
Before FitAll can analyze the data, it must be told a number of things, including:

· Which function to use.

· Which weighting factor to use.

· Which data points to use.

Here's how to do it:

· Click the Analyze > Setup menu selections, press Alt+S or click the  button, located on the toolbar
under the main menu.

The 'Analyze Setup' dialog box will appear. It should look like this:

· Use the Function drop-down listbox to choose function number 0001.
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· When the 'Number of terms in background polynomial' dialog box appears, change the value to one and
click the OK button.

NOTE:
When more than one variation of a function is available, one or more dialog
boxes may appear requesting additional information. 
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· Confirm that the 'Force automatic initial estimates' and 'Limit parameters' check boxes are not checked,
that the 'Analysis Range' is 1 to 10, the 'Analysis Method' is nlls and the 'Monte Carlo' checkbox is not
checked.

· Click on the 'Parameters' tab.

Click the 'Initial Estimates' button. The SetUp dialog's 'Parameters' page should look like this:

· Click the OK button.
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Analyzing the Data
To analyze the current data with the function and other settings selected in the 'Analyze > Setup' dialog
box do the following:

· Click the Analyze > Analyze menu selections, press Alt+N or click the  button, located on the toolbar
under the main menu.

· FitAll will do the analysis and place the results in its 'Fit' window.

Your screen should look like this:

 

The 'Fit window' contains two grids.

The upper grid lists the following information:

· The data file that was analyzed.

· The data set's title.

· The data set's sub-title.

· The name of the function used to analyze the data.
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· The analysis method used (nls, nlad or lls).

· The analysis range; i.e., the data points used.

· The weighting factor that was used.

· The variance of the fit.

· The standard deviation of the fit.

· The number of iterations required to obtain the fit.

The bottom grid lists the following information:

· The names of the resolved parameters.

· The values of the resolved parameters.

· The standard deviations of the resolved parameters.

· Optionally, the relative standard deviation. RSD%, of the resolved parameters

· The names and values of all constants.

· If parameter limits were used, the upper and lower limiting values for each of the parameters.
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Plotting the Fit
To see a graph of the fit:

· Click the View > fit graph menu selections.

· FitAll will open its 'fit graph' window and place the graph in it. Your screen should look like this:

The appearance of the fit graph can be changed by setting its properties in the same way that the data
graph's appearance  is changed.22
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Saving a Graph as a Picture
To save the fit graph as an image, do the following:

· Make sure that the window containing the graph you want to save as a picture is the active window. If it
is not, click the appropriate tab.

· Click the File > Save as... menu selections or click the  button located on the tool bar.

· When the 'Save as...' dialog box appears, enter a name for the graph in the 'File Name' edit field.

· Use the 'Save as Type' drop-down list to choose the type of graphic file to create. FitAll can save a
graph as:

· a Bitmap file (*.bmp).

· a JPEG image file (*.jpg).

· a Portable Network Graphics file (*.png).

· Click the OK button.
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Copying a Graph to the Clipboard
To copy the fit graph as an image to the clipboard so that it can be pasted into other programs, do the
following:

· Make sure that the window containing the graph you want to copy is the active window. If it is not, click
the appropriate tab.

· Click the File > Print to clipboard or the Edit > Copy menu selections.

· The graph will be copied to the clipboard as a bitmap.
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Generating a Report
To generate a MS Word report do the following:

· Click the Edit > Generate Report... menu selections or click the  button to create a MS Word or Excel
report (document) that contains the results of your analysis.

· Each report can contain the contents of any or all of FitAll's windows.

· When you choose Edit > Generate Report... the 'Generate Report' dialog box appears. It looks like this:

· Check the "Report Contents" items that you want to appear in the report.

· Use the "Move Up" and "Move Down" buttons of change the order of the report items.

· Click the OK button to generate the report.
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Entering and Editing Data
To add a data point to the data set in memory:

? Make the 'Data' window the active window by clicking 'Data' tab or by choosing the View > Data
menu selections.

The 'Data' window might look like this:

? Click the Edit > Row Add menu selections, press the Insert key or click the  button.

A data point will be appended to the end of the current data set. The values in each column will be
zero with the possible exception of the last column.  The 'Data' window should now look like this:
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NOTE:
When entering many rows of data it is often useful to allow the pressing Return /
Enter key to automatically add a new row when the cursor is on the last cell in the
table.

To do this select the menu items Options > Preferences > General 2 and check
the "Return / Enter Appends Data Row" checkbox.

? To enter a new value for a number, select the number you want to change by clicking on it or by
using the arrow keys to highlight it.

For example, if you want to edit the values in the data point that was just added to the data set, use
the arrow keys to highlight the eleventh X-value.

The 'Data' window should now look like this:
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? Type in the new number. (For example: 200).

When you start to type the new number, the value you are replacing will be deleted.

? Press the Enter key to accept the new value or press the Esc key to cancel it.

? The 'Data' window should look like this:
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? Change the value of Y to 185 for data point number 11 , by typing 185, and pressing the Enter key.

The 'Data' window should look like this:
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? To save the changed data set, click the menu selections File > Save, press Ctrl + S or click the 
button on the toolbar.

? To save the changed data with a different name, click the menu selections File > Save as... or click

the  button on the toolbar.
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Creating a New Data Set
What's in a Data Set

Creating a Data Set

What's in a Data Set

Each FitAll data set consists of a title, at least three (3) columns of numbers and a heading for each of
the columns. The three columns of data correspond to the X-values, the Y-values and the SigmaY-values.
SigmaY is the value of the measurement error (standard deviation) associated with the Y-value.

For example, if you were keeping a record of the daily noon-time temperature and you had a thermometer
that was marked off in one degree intervals, you would record each temperature as a whole (integer)
number of degrees even if the actual temperature was between two of the graduation marks. In choosing
the number to record, you would choose the lower value if the temperature was closer to it or the higher
value if the temperature was nearer to that marker. The net result is that any given temperature could be
in error by as much as 0.5 degrees. The value of SigmaY for each temperature that you record would then
be 0.5

NOTE:
This is a simplified example. The actual standard deviation, SigmaY, would be on
the order of 0.3.

The errors, SigmaY, can be used by FitAll to weight the data. The result of the weighting is to de-
emphasize those data points that contain large measurement errors so that they do not distort the curve fit
by too much.

All data sets entered into FitAll must contain a set of SigmaY values. If these values are not available or
are not known, use a value of 1 for SigmaY. The result of entering a value of 1 will be to weight the data
equally, even when FitAll may 'think' that it is using a different weighting scheme.

Creating a Data Set

To create a new data set:

· Click the File > New menu selections, press Ctrl+N or click the  button.

The 'New Data' dialog box will appear. It should look like this:

39

39
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NOTE:
If the current data set has not been saved since it was last modified, you will be
asked whether it should be saved before the new data set is created.

If you want to save it, click the Yes button, otherwise click the No button.

· Click in the 'Title' edit box and type in a title for this data set. For example, type: My First Data Set.

· Click in the 'Sub-Title' edit box and type in a sub-title for this data set. For example, type: My First Sub-
Title.

· Click on the '# of columns' spin-edit box to set the number of data columns that you want.

· Click in the 'Data Column Names' table. Use the up and down arrow keys to highlight the name you
want to change. Type in the new column name.

· Press the Enter key to accept the new name or press the Esc key to cancel the entry.

· When you have made all the changes that you want, click the Ok button to accept your choices or click
the Cancel button if you decide not to create a new data set.

FitAll will then switch to the Data window, which will contain one data point. 
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· Edit and enter more data points in the same way as explained in 'Entering and Editing Data '.34



- 42 -

Getting Started GuideHow To,

How To
Introduction

What's New

FitAll Basics

FitAll Fundamentals

Appendix

1

2

8

16

46



- 43 -

Getting Started Guide How To, Add Scripted Functions

Add Scripted Functions
To add your own scripted function to FitAll do the following:

1. Decide on the function that you would like to add and write down an expression for it using "X" as the
independent variable and "P1", "P2", etc. as the parameters that are to be resolved.

For example, if you want to fit your data to a straight line the function would be 
Y = P1 + P2 * X
in which P1 is the intercept and P2 is the slope of the line.

Note that the function (a) has two (2) parameters and (b) is "linear" in its parameters.

2. Make the menu selection Edit > Scripted Ftns.... The "Edit Scripted Functions" dialog that appears
will look like this:

3. Use the Function Number spin edit to choose a function that has not yet been defined; that is, one in
which most of the entries in the dialog are blank.
Or simply edit the entries for an existing function to change its definition.

In this example, edit the definition of function 101.

4. After making your changes the dialog should look like this:
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Note that:
(a) The Description must not be blank. If it is blank the function will not appear in the list of available
analysis functions.
(b) The "Ftn is linear in its parameters" checkbox has been checked because the function is linear in
its parameters.
(c) The names "Intercept" and "Slope" have been assigned to the parameters P1 and P2.

5. Click the "Test using default values" button to make sure that the expression is valid and will give the
expected result when evaluated.
The dialog should look like this



- 45 -

Getting Started Guide How To, Add Scripted Functions

Note that you can change the default X-value and parameter values and test the function evaluation
again.

6. Click the "Save Changes" button to save the scripted function definition.

7. Click the "Done" button. When next setting up an analysis this function will appear in the list of
available functions.
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Getting Help
To get technical or other assistance from MTR Software you can:

Visit MTR Software's website at:

www.fitall.com

Email MTR Software at:

support@fitall.com

Write to MTR Software at:

MTR Software

77 Carlton Street, Suite 808

Toronto ON Canada

M5B 2J7

Telephone MTR Software at:

416-596-1499

Describe your problem or difficulty as completely as you can. We will try to answer your query quickly and
completely.

You should also include your email address as well as your daytime, evening and weekend telephone
numbers.

http://www.fitall.com
mailto:support@fitall.com?subject=FitAll Support
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Adding Functions to FitAll
There are four ways to add your own specialized functions to FitAll.

1. In FitAll version 10 you can use the new "Scripted Function" feature to add functions that can be
defined by a one-line expression and contains one independent variable, X. and up to ten
parameters, P.

2. You can contact MTR Software to get a quotation on the cost of creating a custom FitAll Function
Library for you.

3. The FitAll Programmer's Guide, which is included with FitAll Research Edition, explains:

· how to modify the supplied source code for the User Defined FitAll Function Libraries and 

· how to compile them using Embarcadero / CodeGear / Borland Delphi version 5 to XE2,
FreePascal version 2.2 or later and Lazarus version 1.0 or later. FreePascal and Lazarus are
open source Pascal compilers available from www.freepascal.org and www.lazarus.freepascal.org
. Lazarus is highly recommended.

4. You can contact MTR Software and request that the function be added to one of FitAll's Function
Libraries.

http://www.freepascal.org
http://www.lazarus.freepascal.org
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